Users should no longer encounter errors when downloading Node.js.
From 21:36 UTC to 22:45 UTC, users may have encountered errors when attempting to download Node.js or access Node.js version documentation. This only impacted requests where a response was not held in Cloudflare's cache and was due to an upstream issue with Cloudflare R2 that has now been resolved.
Posted Mar 21, 2025 - 23:51 UTC
Monitoring
As of 22:45 UTC, we are no longer seeing errors generated during Node.js downloads. Cloudflare has also confirmed a fix has been implemented on their end. We will continue to monitor to ensure Node.js downloads are stable.
Posted Mar 21, 2025 - 22:51 UTC
Investigating
Since 21:36 UTC, users may encounter intermittent errors when attempting to download Node.js. This appears to be due to an upstream issue with Cloudflare R2, which we use for hosting Node.js downloads: https://www.cloudflarestatus.com/incidents/v6c7l22vglw5